تطبيقات

يمكن لنظام Android 15 رفع الحد الأدنى من متطلبات التطبيقات وحظر التطبيقات القديمة: تقرير


يمكن لنظام Android 15 حظر بعض التطبيقات الموجودة حاليًا على متجر Google Play أو المتوفرة في أسواق الجهات الخارجية، وفقًا للتقرير. يشاع أن شركة Google ستقدم الجيل التالي من نظام التشغيل الخاص بها لأجهزة Android في النصف الأخير من عام 2024. ومع إصدار Android 15 Developer Preview 2 في 21 مارس، تم عرض العديد من الميزات الجديدة. الآن، يشير أحد التقارير إلى أن جوجل قد ترفع الحد الأدنى من متطلبات التطبيقات مع التحديث القادم لنظام التشغيل.

أبرز تقرير صادر عن Android Police أن متطلبات مجموعة تطوير البرامج (SDK) قد تم تغييرها وتدعم الآن إصدارًا أعلى. مع كل تحديث جديد لنظام التشغيل، تضيف Google ميزات ومعايير أمان جديدة إلى نظام Android البيئي. ومع ذلك، فهو يمنح المطورين وقتًا كافيًا لمتابعة أحدث المتطلبات. على سبيل المثال، حاليًا، في نظام التشغيل Android 14، يُطلب من المطورين استهداف نظام التشغيل Android 6.0 أو Marshmallow، الذي تم إصداره في عام 2015.

كان نظام التشغيل هذا مهمًا لأنه يتطلب من التطبيقات الحصول على موافقة المستخدمين للحصول على أذونات حساسة بشكل منفصل مثل الوصول إلى الكاميرا ودفتر العناوين وسجلات المكالمات والمزيد. ولكن الآن، وجد التقرير أن إصدار Android 15 DP2 لا يسمح بتثبيت التطبيقات التي تستهدف SDK 23 المستندة إلى Android 6.0 على الأجهزة. وبدلاً من ذلك، فهو يطلب الآن إصدار SDK 24 وهو Android 7.1.

ومن خلال إجراء اختبار لمحاولة تثبيت تطبيق لم يتم رفعه إلى SDK 24، وجد التقرير أن الهاتف الذكي الذي يعمل بنظام Android 14 كان قادرًا على تثبيته وتشغيله بسهولة. ومع ذلك، عندما تم إجراء التجربة على هاتف Google Pixel 8 Pro الذي يعمل بنظام Android 15 DP2، ظهر خطأ ينص على “INSTALL_FAILED_DEPRECATED_SDK_VERSION”. حتى عند محاولة تحميل التطبيق، ظهر نظام التشغيل رسالة تفيد بأن التطبيق غير آمن للتثبيت.

الرسالة ليست جديدة وتطبيقات التحميل الجانبي تطالب عمومًا بهذا التنبيه. ومع ذلك، فإن الجزء المثير للدهشة هو أن تثبيت على أي حال الزر الذي يظهر بعد ذلك لم يفعل أي شيء ولم يكن من الممكن تثبيت التطبيق. وبناءً على النتائج، يبدو أن التطبيقات التي لا تزال تستهدف Android 6.0 من المرجح أن تتوقف عن العمل بعد إصدار Android 15 عالميًا. ومع ذلك، تجدر الإشارة إلى أن العديد من التطبيقات اليوم لا تستهدف SDK 23 حيث يحاول المطورون زيادة إصدار التطبيق إلى أحدث معايير Android.


قد يتم إنشاء الروابط التابعة تلقائيًا – راجع بيان الأخلاقيات الخاص بنا للحصول على التفاصيل.

اترك تعليقاً

لن يتم نشر عنوان بريدك الإلكتروني. الحقول الإلزامية مشار إليها بـ *